const regex = /,?(?!CN\d+)\b[\w~ -]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',?(?!CN\\d+)\\b[\\w~ -]+', 'g')
const str = `CN98765432~-~ECN for A01234 Rev A,CR00098765~-~ECR for A12345 SOME PART NAME,CN12345678~-~ECN for A12345 Rev A`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);