using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"node_modules\/(?!@devplat\/bestie-privacy.*|whatwg-fetch).*";
string input = @"node_modules/whatwg-fetch/fetch.js
node_modules/@devplat/bestie-privacyprefences-ts-client/dist/index.js
node_modules/@babel/cli/index.js";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}