# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\(([a-z -]+)\w+?(\d+)\W+\1\w+\)/Gain_$2($1)/gmi;t' <<< "(beginner_post12 - beginner_baseline)
(intermediate_post5 - intermediate_baseline)
(framework notes_posttest4 - framework notes_baseline)
(note-taking instruction_posttest33 - note-taking instruction_baseline)
"