using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<LongDate>(?P<Day>\d+)[\s ]+(?P<Month>January|February|March|April|May|June|July|August|September|October|November|December)[\s ]+(?P<Year>\d{4}))";
string input = @"of 19 September 2006 in";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}