const regex = new RegExp('(?P<LongDate>(?P<Day>\\d+)[\\s ]+(?P<Month>January|February|March|April|May|June|July|August|September|October|November|December)[\\s ]+(?P<Year>\\d{4}))', 'giu')
const str = `of 19 September 2006 in`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}