$re = '/(?P<LongDate>(?P<Day>\d+)[\s ]+(?P<Month>January|February|March|April|May|June|July|August|September|October|November|December)[\s ]+(?P<Year>\d{4}))/iu';
$str = 'of 19 September 2006 in';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);