$re = '/maxiobe namespaces/m';
$str = '<?php
require_once __DIR__ . \'/src/Models/Device.php\';
require_once __DIR__ . \'/src/Models/Smartphone.php\';
use App\\Models\\Device;
use App\\Models\\Smartphone;
$myDevice = new Device();
$myDevice->turnOn();
$myDevice->turnOff();
echo "<hr>";
$myPhone = new Smartphone();
$myPhone->turnOn();
$myPhone->takePhoto();
$myPhone->turnOff();
devices.php:
<?php
namespace App\\Models;
class Device {
public function turnOn(): void {
echo "Gerät eingeschaltet.<br>";
}
public function turnOff(): void {
echo "Gerät ausgeschaltet.<br>";
}
}
Smartphone.php:
<?php
namespace App\\Models;
class Smartphone extends Device {
public function takePhoto(): void {
echo "Foto gemacht! 📸<br>";
}
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);