#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=href="|src=")(?!https?:\/\/)[^"]*"
Local $sString = "<a href="joycat"></a>" & @CRLF & _
"<a src="joycat"></a>" & @CRLF & _
"<a href="http://joycat"></a>" & @CRLF & _
"<a src="http://joycat"></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")