package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)@(\w+)`)
var str = `first.name@google1.co.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}