import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^\"]*)\".*";
final String string = "2014-03-20 16:53:39.741 -0700 Information 638 NICOLE Client \"[WebDirect]\" opening a connection from \"24.114.54.155 (24.114.54.155)\" using \"iPad Safari 7.0 [fmwebdirect]\".\n"
+ "2014-03-20 16:53:39.741 -0700 Information 94 NICOLE Client \"[WebDirect] (24.114.54.155) [24.114.54.155]\" opening database \"ProShopPartner_v1\" as \"[Guest]\".\n"
+ "2014-03-20 16:58:45.163 -0700 Information 98 NICOLE Client \"[WebDirect] (24.114.54.155) [24.114.54.155]\" closing database \"ProShopPartner_v1\" as \"[Guest]\".\n"
+ "2014-03-20 16:58:45.163 -0700 Information 22 NICOLE Client \"[WebDirect] (24.114.54.155) [24.114.54.155]\" closing a connection.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}