import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?:\\d+_){4})(card\\d+)_(port\\d+)";
final String string = "192_168_10_2_card02_port01_other_text_with_card_or_port\n"
+ "10_22_1_200_card4_port5_another_string_with_port_or_card\n"
+ "something_else_with_card_or_port_in_it\n\n\n"
+ "And in a second call, I'd like to match a different word in these strings.\n"
+ "192_168_10_2_card02_port01_other_text_with_card_or_port\n"
+ "10_22_1_200_card4_port5_another_string_with_port_or_card\n"
+ "something_else_with_card_or_port_in_it";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}