import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{1,3}[\\s]*?[_|.,:;][\\s]*?[0-9]{1,3}[\\s]*?[_|.,:;][\\s]*?[0-9]{1,3}[\\s]*?[_|.,:;][\\s]*?[0-9]{1,3}[\\s]*?:[\\s]*?[0-9]{3,6}";
final String string = "127 , 0 _ 0; 1 : 45345\n"
+ "zapraszamy na {1.2.3.1:4564}\n"
+ "ksk.sls.ss.ll:asas\n"
+ "121.121.12.11:4545\n"
+ "127 . 0 . 0 . 1 : 1234 asdasdsadafasdgdsfs sdfgsdfg\n"
+ "127 . 0 . 0. 1 : 45345 ksasdklasda ka sdk laksj dlkasj dlka sdlaksjd laksjd lkakjsdl ajksdl a\n"
+ "121.121.12.11:4545\n"
+ "127.0.0.1:1234\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}