import Foundation
let pattern = #"[0-9]{1,3}[\s]*?[_|.,:;][\s]*?[0-9]{1,3}[\s]*?[_|.,:;][\s]*?[0-9]{1,3}[\s]*?[_|.,:;][\s]*?[0-9]{1,3}[\s]*?:[\s]*?[0-9]{3,6}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
127 , 0 _ 0; 1 : 45345
zapraszamy na {1.2.3.1:4564}
ksk.sls.ss.ll:asas
121.121.12.11:4545
127 . 0 . 0 . 1 : 1234 asdasdsadafasdgdsfs sdfgsdfg
127 . 0 . 0. 1 : 45345 ksasdklasda ka sdk laksj dlkasj dlka sdlaksjd laksjd lkakjsdl ajksdl a
121.121.12.11:4545
127.0.0.1:1234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}