#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?<=connectionId=)\d+"
Local $sString = "http://localhost:10001/Member/GetConnection?всякаяНенужнаяХуита&connectionId=100500&всякаяНенужнаяХуита"
Local $sSubst = "123"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)