$re = '/^([1-9\d{2,}|[3-9]\d|2[5-9])000$/m';
$str = '10000
25000
25100
30
30000
25000100
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);