const regex = /(.+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+)', 'g')
const str = `A
B
C`;
const subst = `$1_$1_suffix`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);