use strict;
my $str = 'A
B
C';
my $regex = qr/(.+)/p;
my $subst = '$1_$1_suffix';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";