$re = '/(.+)/';
$str = 'A
B
C';
$subst = "$1_$1_suffix";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;