import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"(email|phone)\\\":[^,]*,?";
final String string = "\"email\": abc@rrr.ttt,\n"
+ "\"phone\":\"1234545353\"";
final String subst = "\"$1\":\"****\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}