#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?(?=9999)9999(?:\.0+)?|\d{1,4}(?:\.\d{1,2})?)$"
Local $sString = "9999" & @CRLF & _
"9999.0" & @CRLF & _
"9998.99" & @CRLF & _
"9999.00" & @CRLF & _
"9999.01" & @CRLF & _
"10000.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")