const regex = /(http[s]?:\/\/)?([^\/\s]+\/)(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http[s]?:\\\/\\\/)?([^\\\/\\s]+\\\/)(.*)', '')
const str = `http://video.google.co.uk:80/videoplay?docid=-7246927612831078230&hl=en#hello`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}