$re = '/(http[s]?:\/\/)?([^\/\s]+\/)(.*)/';
$str = 'http://video.google.co.uk:80/videoplay?docid=-7246927612831078230&hl=en#hello';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);