#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Yours sincerely,\s+(?<name>[^\n]+)\s+(?<email>[^\n]+)\s+(?<address>[^\n]+?(?<postcode>\d+))"
Local $sString = "Yours sincerely," & @CRLF & _
"" & @CRLF & _
"Persons Name" & @CRLF & _
"test@example.com.au" & @CRLF & _
"" & @CRLF & _
"Sydney, New South Wales 2152"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")