const regex = /^(?3)*\)*$(()((?(2)|\)*)(\((?1)*(\)|$)|0|"[^\n"]*.?|(1|(2|(3|4(?3))(?3))(?3))(?3))))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?3)*\\)*$(()((?(2)|\\)*)(\\((?1)*(\\)|$)|0|"[^\\n"]*.?|(1|(2|(3|4(?3))(?3))(?3))(?3))))?', 'gm')
const str = `Truthy:
0
)
(
"
()
""
10
400010
210010
("")00
3"""""
2(2(2(0)0)0)0
2"010""44)()4"
)31(0)0(20102010
())2)1))0"3())"))
3("4321("301(0)21100"4")"123"00)40"121"31000""01010
Falsy:
1
1(310
12(010
4"00010"
3120102100
20(2((0)(0)))
2(2(2(0)0)0)01)
4(0102)00)00000
2"00"("00"2(""))
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}