#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^\/board\/(.*)t(\d+)\.html$"
Local $sString = "/board/here-is-the-title-t1234.html"
Local $sSubst = "http://example.com/forum/$1$2 permanent;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)