$re = '/^\/board\/(.*)t(\d+)\.html$/';
$str = '/board/here-is-the-title-t1234.html';
$subst = "http://example.com/forum/$1$2 permanent;";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;