$re = '/[\d,.]+/';
$str = '£4,342.32
£65.00
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);