package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/[\w-]+(\.[\w-]+)*(:\d{1,5})?`)
var str = `http://www.memberpress.com
https://www.memberpress.com
http://localhost:3000
http://example123.com
hi there. what is up g?
Here's a phone number we don't want to match (888) 555-1111
/wp-content/uploads/10/1/cool.pdf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}