package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:\s*|\r)+GO(\s*);*\s*(?:\r|\n)`)
var str = `GO;
[11-02-2016 08:14] Rene Krone:
/* To prevent any potential data loss issues, you should review this script in detail before running it outside the context of the database designer.*/
BEGIN TRANSACTION
SET QUOTED_IDENTIFIER ON
SET ARITHABORT ON
SET NUMERIC_ROUNDABORT OFF
SET CONCAT_NULL_YIELDS_NULL ON
SET ANSI_NULLS ON
SET ANSI_PADDING ON
SET ANSI_WARNINGS ON
COMMIT
BEGIN TRANSACTION
Go ;
ALTER TABLE dbo.ResultCodes ADD
ShortDescription nvarchar(50) NULL,
EnglishDescription nvarchar(100) NULL
gO;
ALTER TABLE dbo.ResultCodes SET (LOCK_ESCALATION = TABLE) GO PRINT 'PLEASE GO ; '
GO
COMMIT
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}