re = /<table>.*<\/table>(?=\n*<div>)/m
str = '<div>
<table></table>
<table><div>sdfgsdfbdcsbsdf<div></table>
<table><div>asdfasdgadfgsdf<div></table>
<div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end