package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((^\d+((\s)\d+)*$)|(^\d+(,)\d+)*$)`)
var str = `123,455
123 456
12,45 67
12 34,56
1 2 3 4
1,2,3 4
123, 56
12 ,356
3 4 5,89`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}