$re = '/<img.+?class=".*?red.*?"/';
$str = '<img class="lorem ipsum red" />
<img class="red" />
<img class="lorem red ipsum dolor" />
<img class="red ipsum" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);