#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<namespace>(?:[a-zA-Z][a-zA-Z0-9_-]*)(?:\.[a-zA-Z][a-zA-Z0-9_-]*)+)::(?<rm_publisher>[a-zA-Z]+)-(?<rm_package>[a-zA-Z][a-zA-Z0-9_]+)-(?<rm_class>[a-zA-Z]+)\.(?<concept_name>[a-zA-Z][a-zA-Z0-9_-]+)\.(?<release_version>v\d+(?:\.\d+){0,2})(?:-(?<version_status>[a-zA-Z0-9]+))?(?:\.(?<build_count>\d))?$"
Local $sString = "Valid examples:" & @CRLF & _
"org.openehr.test::openehr-ehr-comp.test.v1.0.1-alpha.1" & @CRLF & _
"org.openehr.test::openehr-ehr-comp.test.v1" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Invalid examples:" & @CRLF & _
"org.openehr.test" & @CRLF & _
"openehr-ehr-comp.test.v1" & @CRLF & _
"org.openehr.test::openehr-ehr-comp.test.v1.0.1-alpha.1c" & @CRLF & _
"org.openehr.test::openehr-ehr-comp.test.v1.0.1+alpha.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")