package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<namespace>(?:[a-zA-Z][a-zA-Z0-9_-]*)(?:\.[a-zA-Z][a-zA-Z0-9_-]*)+)::(?<rm_publisher>[a-zA-Z]+)-(?<rm_package>[a-zA-Z][a-zA-Z0-9_]+)-(?<rm_class>[a-zA-Z]+)\.(?<concept_name>[a-zA-Z][a-zA-Z0-9_-]+)\.(?<release_version>v\d+(?:\.\d+){0,2})(?:-(?<version_status>[a-zA-Z0-9]+))?(?:\.(?<build_count>\d))?$`)
var str = `Valid examples:
org.openehr.test::openehr-ehr-comp.test.v1.0.1-alpha.1
org.openehr.test::openehr-ehr-comp.test.v1
Invalid examples:
org.openehr.test
openehr-ehr-comp.test.v1
org.openehr.test::openehr-ehr-comp.test.v1.0.1-alpha.1c
org.openehr.test::openehr-ehr-comp.test.v1.0.1+alpha.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}