$re = '/\d+(?:\.\d+)*/m';
$str = 'text 304.33.44.52.03.001 text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);