const regex = /{#val#}|([!-\/:-@[-`{-~])/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{#val#}|([!-\\\/:-@[-`{-~])', 'gi')
const str = `Hi {#VAL#}, Thank you {#val#}{#val#} for &visting us!`;
const subst = `.{0,5}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);