import Foundation
let pattern = ##"{#val#}|([!-\/:-@[-`{-~])"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = ##"Hi {#VAL#}, Thank you {#val#}{#val#} for &visting us!"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #".{0,5}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)