package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`D\[(.*?)\]`)
var str = `D[date-string] T[time-string] N[name-string] M[message-string]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}