package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?:\/\/)?(www\.)?([\w]+\.)+[\w]{2,63}\/?$`)
var str = `http://google.com
www.google.com
https://google.com
http://www.google.com
www..com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}