$re = '/\(([^,\s\)]+)(?:\s*,\s*([^,\s\)]+))*\)/';
$str = 'someFunc(param)
someFunc(param, param2)
someFunc(param, param2, param3)
someFunc(param, param2, param3, param4)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);