import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\"(\\\\.|[^\"])*\\\")|(\\'(\\\\.|[^'])*\\')";
final String string = "function jamel (a,b) { }\n\n"
+ "on the (favorit () )\n\n"
+ "on ( (jdjs), () ) (());\n"
+ " \"sefsf sfsf '' sfsfsfsfs\" \"jslfksj slfkj on\" 'sd \\' sdfsfsf \\' \" sdfsf\" fsfs'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}