const regex = /[0-9]+\.[0-9]{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]+\\.[0-9]{2}', 'g')
const str = `Order Details: item one 1 @ \$33.99 \$33.99 item two 100 @ \$3.99 \$399.00 item three 10 @ \$333.99 \$3339.90 Subtotal: 33333.99 Shipping: 10.27 Tax: 0.00 Total: 444444.26`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}