$re = '/[0-9]+\.[0-9]{2}/';
$str = 'Order Details: item one 1 @ $33.99 $33.99 item two 100 @ $3.99 $399.00 item three 10 @ $333.99 $3339.90 Subtotal: 33333.99 Shipping: 10.27 Tax: 0.00 Total: 444444.26';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);