use strict;
my $str = 'Hi!
My name is:
Bob
I am from the USA.';
my $regex = qr/(?m)^\h+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";