using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((max-age=\d+)|(pin-sha256=\""[\d\w]+=?=?\""));\s{0,1})+includeSubDomains";
string input = @"pin-sha256=""WoiWRyIOVNa9ihaBciRSC7XHjliYS9VwUGOIud4PB18=""; pin-sha256=""JbQbUG5JMJUoI6brnx0x3vZF6jilxsapbXGVfjhN8Fg=""; max-age=300; includeSubDomains";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}