import Foundation
let pattern = #"(((max-age=\d+)|(pin-sha256=\"[\d\w]+=?=?\"));\s{0,1})+includeSubDomains"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"pin-sha256="WoiWRyIOVNa9ihaBciRSC7XHjliYS9VwUGOIud4PB18="; pin-sha256="JbQbUG5JMJUoI6brnx0x3vZF6jilxsapbXGVfjhN8Fg="; max-age=300; includeSubDomains"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}