#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m),?[ ]*([^',\n]*(?:'[^'\n]*'[^',\n]*)*)"
Local $sString = "21, 2, '23.5R25 ETADT', 'description, with a comma'" & @CRLF & _
"22, 1, '26.5R25 ETADT', 'Description without a comma'" & @CRLF & _
"23, 5, '20.5R20.5', 'Another description with ; semicolumn'"
Local $sSubst = "\1\t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)