package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\h+`)
var str = `I'm just so peachy, right now`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}