$re = '/^http:\/\/(?!www\.)\w+\.\w+(?:\/.*)?$/m';
$str = 'http://www.host.com
http://host.com
www.host.com
host.com
http://\'anything.\'host.com
http://www.host.com
http://sub.host.com
http://host.com/asdsdad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);