#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]|[1-5][0-9]|60(\.0{1,2})?$)(\.[0-9]{1,2})?$"
Local $sString = "0" & @CRLF & _
"0.01" & @CRLF & _
"1" & @CRLF & _
"1.0" & @CRLF & _
"9" & @CRLF & _
"10" & @CRLF & _
"19" & @CRLF & _
"20" & @CRLF & _
"21" & @CRLF & _
"21.23" & @CRLF & _
"21.234" & @CRLF & _
"29" & @CRLF & _
"30" & @CRLF & _
"31" & @CRLF & _
"39" & @CRLF & _
"40" & @CRLF & _
"41" & @CRLF & _
"49" & @CRLF & _
"50" & @CRLF & _
"53" & @CRLF & _
"59" & @CRLF & _
"60" & @CRLF & _
"60.00" & @CRLF & _
"60.01" & @CRLF & _
"61"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")